ImpressPages 4.7.0

Fixing compatibility issues with the changes on Google Maps. Now Google forces each website to provide a unique Google Maps API key for maps to work. Otherwise instead of the map you'll see a message below.

Map widget is included by default to ImpressPages core. Unfortunately recently Google has changed his mind and now requires everyone (except existing websites) to generate an API key to use Google Maps. Without the key, new installations can't use Map widget.

To address this issue we have released an update that enables entering Google Maps API key in website's configuration page:

If you update from an established domain, you don't have to fill in this field and your website should work as usual. If you install a fresh copy of ImpressPages or move to another domain you have to fill in this field, otherwise after placing the Map widget, you will see the following notification:




comments powered by Disqus